Jump to content
Chinese-forums.com
Learn Chinese in China

  • Why you should look around

    Since 2003, Chinese-forums.com has been helping people learn Chinese faster and get to China sooner. Our members can recommend beginner textbooks, help you out with obscure classical vocabulary, and tell you where to get the best street food in Xi'an. And we're friendly about it too. 

    Have a look at what's going on, or search for something specific. We hope you'll join us. 
imron

Pinyinput - Type Pinyin with Tone Marks

Recommended Posts

Guangxi Shane

When I use Pinyinput in Gmail and on Chinese-Forums, as I'm typing text, it continues to display the letters up and to the left of where the cursor is located. As soon as I type the number for the tone, though, the text appears where I want it to be, so there's really not a problem. If I want to, I can click on and drag the little box of text that is displaying the letters I'm typing down to where I actually want the text to go. Alternatively, I can just get used to the fact that Pinyinput displays text, as I'm typing it, in a place other than where my cursor is located. Maybe that's the way it's supposed to work???

 

When I use Pinyinput in MS Notepad the letters appear in the same place as the text I'm typing.

 

I'm using Windows 7. 

Share this post


Link to post
Share on other sites
Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

imron
Maybe that's the way it's supposed to work???

No, that's not the way it's supposed to work.  The little box should be next to the input cursor.  I'll investigate it further.  What browser are you using?

Share this post


Link to post
Share on other sites
Guangxi Shane

 

 

No, that's not the way it's supposed to work.  The little box should be next to the input cursor.  I'll investigate it further.  What browser are you using?

 

Chrome

Share this post


Link to post
Share on other sites
Jing Xi

Man - this is bloody fantastic!  Thanks a lot.

Share this post


Link to post
Share on other sites
imron

Glad you like it

Share this post


Link to post
Share on other sites
Shelley

I only just started to use Pinyinput 2 days ago, although I have had it on my machine for awhile. The first time I used it it worked fine, excellent stuff. Then I discovered it had taken over my language bar and I couldn't use my IME.

I had to uninstall Pinyinput to regain my IME.

 

Not sure if this is connected but also Perapera stopped working at the same time, i have tried uninstalling and reinstalling but no change. I have emailed the developer about that and we will see what they say.

Share this post


Link to post
Share on other sites
Manuel

Maybe try my app QuickPinyin (link in my signature)

Share this post


Link to post
Share on other sites
Shelley

Thanks Manuel, I might well try it, I wanted to let imron know that I had an issue with it, it might be me or it might be Pinyinput but I thought it best to let him know in case there is a problem with Pinyinput that he is unaware of.

Share this post


Link to post
Share on other sites
Shelley

Just received a reply from Perapera, they are having an issue with an update to firefox. so unrelated to Pinyinput.

Share this post


Link to post
Share on other sites
imron
Then I discovered it had taken over my language bar and I couldn't use my IME.

Are you able to explain this in more detail?  What do you mean it had taken of the language bar?

Share this post


Link to post
Share on other sites
Shelley

When I chose Chinese input from the language bar I get a choice of Microsoft IME or Pinyinput.

 

I used Pinyinput the other day, it worked fine. Today when I chose ch from the language bar I had the same choices but when I chose Microsoft IME it went away and I could only choose Pinyinput, no matter what I did the only way to get my IME back was to uninstall Pinyinput.

Share this post


Link to post
Share on other sites
Gharial

Hi Imron, I'm using Windows 10 on a 64-bit PC (formerly a w7 laptop that I unfortunately had to reformat, and then couldn't face re-installing over 3 years of w7 updates on!). Should the insertion of apostrophes in Pinyinput be automatic? For example, when typing Xi1an1 without pause, should the output automatically become Xī'ān? I find that when I try to type just that (Xi1an1), my PC makes a harp-like sound (the w10 "does not compute" default) and I end up with just xīn1. Anyway, it isn't much bother to add the apostrophe manually before proceeding to the next syllable, but I was just wondering if this was a glitch or something that maybe hadn't been brought to your attention (I've only read back through the thread to about 2012 as w10 is pretty recent, assuming that's the culprit!).

Share this post


Link to post
Share on other sites
imron

Do you recall if it used to work properly on older versions of Windows?

Share this post


Link to post
Share on other sites
Gharial

Believe it or not this is the first time I've used anything like Pinyinput (I used to make do with laboriously copying and pasting from the MDBG Pinyin inputter LOL, but I suppose I didn't have THAT much stuff to type up back then). As there must be plenty of people using it fine with w7 I guess it's just something to do with w10 (have [m]any other CF members made the switch?) rather than my unique :):wink: laptop. There's another w7 computer (a desktop PC) in my household though, that's maybe due a switch to w10 (lots of failed, well, aborted updates, getting very laggy in comparison, etc), so if you like I'll give Pinyinput a before-if-not-after go on that when I have access to it! (Could take at least a day or two though, and its owner might want to stick with w7 regardless, so...).

Share this post


Link to post
Share on other sites
imron

Ok, I'm guessing it's something that will happen on all versions then, rather than just a regression on win10.  From memory, the apostrophe detection is very rudimentary and just always checks at the start of any syllable that requires one (those starting with a, e or o, when it's not the start of a word).

Share this post


Link to post
Share on other sites
Wahed

This seems to be a good way to type Yale Cantonese except for one problem. Is there a way to type tone marks on consonants? If not, could this be added?

Share this post


Link to post
Share on other sites
imron

There is a way to type tone marks on consonants.

 

Just open the configuration dialog (the button on the toolbar that looks like gear cogs) and choose 'Unchecked' input mode and make sure 'Allow tone marks over consonants' is checked.

 

Then just type the tone number after the consonant, e.g. n3 will give you ň.  You can change between 'Checked' and 'Unchecked' mode by pressing Ctrl+.

  • Like 2

Share this post


Link to post
Share on other sites
prashant121

thanks for a useful tool  :D

Share this post


Link to post
Share on other sites
imron

Glad you find it useful!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×