Jump to content
Chinese-forums.com
Learn Chinese in China

  • Why you should look around

    Since 2003, Chinese-forums.com has been helping people learn Chinese faster and get to China sooner. Our members can recommend beginner textbooks, help you out with obscure classical vocabulary, and tell you where to get the best street food in Xi'an. And we're friendly about it too. 

    Have a look at what's going on, or search for something specific. We hope you'll join us. 
imron

Pinyinput - Type Pinyin with Tone Marks

Recommended Posts

imron

Also, running the programs as standalone apps shouldn't be a problem.  IMEs work at the system level and their usage should be mostly transparent to the application in question unless the application has tried very hard to get around it.

Share this post


Link to post
Share on other sites
Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

klaatu

Thank you for the reply. I figured that might be the case, and meant to test it on another desktop this evening.

I only have the default US kb installed, and pinyinput 64 bit, bound under it.  Nothing else, and no other language packs installed.

The language bar is configured just the same as your screenshot, that is the "having trouble with displaying" part.  I don't know why it's hiding, maybe something is broken, or a missing file or registy entry.  I spent some time troubleshooting that without progress, so for now it just isn't showing up.

Since I have no other keyboards installed, and the native pinyinput tool appears on its own, and the ime works in some applications, I didn't keep looking for other ways to make it appear.  ctfmon is running, and as far as I can tell has all its dlls, muis, and registry entries, so that's not it.  I did this work, IT support for many years, & although I'm not a coder, I have a pretty good sense of when to redirect my energy after futile headbanging, that's why I thought I would ask next

I tried a few other things, it appears fine in regedit, and various other windows components.  It does appears in media player classic home theater, which is also running in its own folder without installation, so that must not be the sole issue.   Yet in Psi+, an xmpp chat app that also runs from a folder without installation, there is nothing.  Psi is built with Qt, I don't think mpc-ht is, but dunno if that is any clue

This is a bare windows with absolutely nothing else installed, all the apps are portable standalones to keep it that way, many of them thinapps that can't write to the system, except in the sandbox.  It won't come up in any of the thinapps, including the browser and email client, where it would be nice.  I might try rebuilding the packages on a system with pinyinput already installed, just to see if there is any change

It's a mystery and I thank you for the help and suggestions.  Now that I'm aware there isn't an already known issue with this, and you are also focusing on the language bar, I'll spend some more time digging into that. I had never noticed previously to installing pinyinput, I wasn't using any ime.

It's a fairly simple system to reclone, might be the final solution.  But it's also an opportunity to discover something, a failing I have, having been in this work.  Problems seem to seek out problem solvers

Thanks for letting me know that it does work in the trademanager, that is my primary focus atm.  I'll test all this again tonight on another system and report results, but if it's working for you then you already know that answer :)


 

Share this post


Link to post
Share on other sites
imron

Can you provide link to a downloadable version of one of these standalone programs so I can test it to eliminate that possibility (just zip it up and stick it on a download site somewhere).

 

I'm also curious about how you are running these in sandboxes and what other effects the sandboxing might have.  Pinyinput consists of only a single file pinyinput.ime which needs to exist in the Windows\System32 directory.  If the sandboxing isolates this directory and pinyinput.ime doesn't exist there, then it won't work in the sandboxed apps.  There may also be issues with sandboxed registry settings that don't get set by the Pinyinput installer.

Share this post


Link to post
Share on other sites
Manuel

Klaatu, I am won't explicitly hijack this thread but, seeing that you are a fan of portable apps, I'll just point you to the link in my signature below.

Share this post


Link to post
Share on other sites
klaatu

Sorry I wasn't able to respond earlier, Friday filled up with work, Saturday has been restful.  I have things working now, mostly

Seems there  was a spectrum of small issues, none of it anything to do with the standalone nature of the applications,  or the sandboxes.  The vmware thinapps have no problem reading in the system folders, it's the writing in those directories where they are restricted.  And they can see the registry, but any changes they make to it are kept within their own folders. So there shouldn't have been any problem, & I know this, which helped me to confuse myself.

I tested pinyin input on another win7 system, and it worked, everything as you reported, so I re-tackled the language bar, finally importing registry and files from the working system, which brought it into visibility.  I think there may have been a dll missing from the windows\ime folder.  At that point, I could see a little more what was happening.

The non-working apps, firefox, thunderbird, trademanager, psi+, were still not playing along, but in the language bar I could see that as I moved to/from each window, the round blue pinyinput icon would appear when it was working, and then when the active window was one that wasn't working, the icon would change to 'EN', just like in front of the US keyboard, to the left of it. Seemed odd, and didn't suggest an immediate solution, but in doing that I realized that the misbehaving apps were all 32 bit.  The Media Player Classic was the 64 bit version, and worked.  This made me wonder a little about why, in Region & Language | Keyboards & Languages | Text Services & Input Languages, under the  English | Keyboard | US, it said "pinyinput (64bit only)"

I read here, up a little earlier, when you were bringing 64 bit goodness to pinyinput, but didn't see any mention of this.  I looked at the working win7x64 system, there it only said 'pinyinput'.  I uninstalled it there and reinstalled while monitoring changes; I didn't see any additional binary, nothing going into the syswow64 folder.  So then I removed and reinstalled pinyinput on the troublesome system, and when it came back, this (64bit only) advisory was no longer present.  Is it possible the installer functions differently somehow on a system with a misbehaving language bar?

That seemed to bring more progress, now the trademanager was working, and I was pretty ecstatic, but still no joy in ff, tb, or psi+.  Despite this chain of confusion, some pondering made me realize that I had previously closed the trademanager, and restarted it for the test, after the pinyinput ime had been reinstalled.  The browser, email, and chat apps all run constantly, had never been restarted since the beginning of this. And that proved to be the last solution.

"After installing the pinyinput ime, running applications may need to be restarted before they are able to use it"

So finally everything works.  Thank you so much, and sorry you went to the trouble of testing it when I hadn't yet tried on another system

Now I'm on to discovering the secret to typing chinese characters, pinyin with tone marks, and english, all in the same document  :)

小 女    Xiǎo nǚ     Young Woman
小女     Xiǎonǚ      Daughter

some magical combo of ime, keyboard, font, and encoding?


Manuel, no worries, I could be accused of hijacking my own thread with all this...thanks for the link, I'll take a look, could be useful on the flashdrive when I am traveling
 

Share this post


Link to post
Share on other sites
imron

Ah, yes, when I mentioned a single file above, I had forgotten about 32/64bit stuff.

 

32bit processes can only load 32bit dlls and 64bit processes can only load 64bit dlls.  IMEs are just DLLs and so Pinyinput actually contains 2 files - one 64bit and one 32bit. One gets placed in c:\windows\system32 and on 64bit systems one also gets placed in c:\windows\syswow64.

 

The installer doesn't do anything with the language bar.  All it does is detect if it's a 32bit or a 64bit version of windows so it knows which dlls to install where, and then it optionally rewrites the dll's region depending on the choice made in the installer.  Then it just calls the standard Windows API functions to install an IME.

 

Anyway, glad to hear you got things working in the end.

Share this post


Link to post
Share on other sites
klaatu

oh, so it *does* install a copy in syswow64.  Now I look , and there it is.  On the test system, where I first verified that it was working, the installation monitor utility that I use did not pick that up, and I didn't go looking manually.  On this initially borked system, it must have not copied that one on the first install, no idea why.  what a cluster!

Thanks for the details.  now back to fun, the China dream looms...

Share this post


Link to post
Share on other sites
Elizabeth_rb

Hiya Imron!

 

Just wanted to let you know, (as requested), that pinyinput has turned itself on without my having made a single keystroke, every time I upload photos from my camera.  It comes on just as I'm moving files from the camera disk to the laptop.  If you need me to, I'll make detailed notes of exactly what happens at what point and so on, but I can work around it.=)

 

BW. :)

Share this post


Link to post
Share on other sites
imron

Please do.

If you can also note what version of windows you are running that would be good, as well as a screen shot of control panel showing what keyboards layouts you have installed (control panel: Region and Language -> Keyboards and Language -> Change Keyboards) and which one is the default.

Share this post


Link to post
Share on other sites
Elizabeth_rb

Goodness!  I'll try.:)  It's just happened again (which reminded me to quickly check back here), but I don't really have the time just now and am dealing with monstrous amounts of aggravation, so I'll need to get back to you in a couple of days.

 

Many thanks!  I really like Pinyinput and it's proving v useful in compiling my teaching materials.  It's well worth the suggested donation (which I made) :)

Share this post


Link to post
Share on other sites
imron

Ok, no rush, and thanks for the donation.

Share this post


Link to post
Share on other sites
Elizabeth_rb

As dee good book say: The worker is worthy of his wages.

 

:)

Share this post


Link to post
Share on other sites
wetutoring1

Hi Imron,

 

Great Invention, even in 2014!

 

I have been looking for a software that can type Pinyin tone marks in the past few months.

 

I plan to use this for my blog, to continue sharing one Chinese word or phrase a day for people who are learning Chinese.

 

Definitely will try it out today!  Thank you!

 

William

Share this post


Link to post
Share on other sites
imron

Glad you like it.  Check out my signature for other tools that are useful for Chinese learners.

 

P.S. you might also want to read our Guidelines for Commercial Posters.  I've removed a bunch of gratuitous links from your post.  It's usually much better to use a signature (configured in your profile) for that.

Share this post


Link to post
Share on other sites
Guangxi Shane

Hi Imron,

 

Is there, by any chance, a Pinyinput app for Google Chrome? I searched but wasn't able to find one...

 

Thanks,

 

Shane

Share this post


Link to post
Share on other sites
imron

Pinyinput works at the OS level and not the app level. It will work with any program that runs on windows.

Share this post


Link to post
Share on other sites
Guangxi Shane

My original question was about  getting Pinyinput for my Chromebook. Since the OS is Chrome, it sounds like that's not possible. The Chrome OS offers a simplified Chinese IME, but no way that I know of to type pinyin. Is there any other way to get pinyin when I'm using a Chromebook? Something online maybe? I'm always trying to cut and paste from online dictionaries like MDBG, but the font and color of the text comes out different...

 

A different, but related, question: Last week I downloaded Pinyinput to use on my desktop computer that's running MS Windows (thank you). Initially it worked great, and I was really happy with it. Today, for some reason, when I try to use Pinyinput the text doesn't appear where my cursor is. I can see what I'm typing, but it's several inches above where I want it to go and it's in a strange, small font. It looks like it's inside of a little grey box??? Any idea what I can do to fix this?

 

Thanks

Share this post


Link to post
Share on other sites
imron

Ah right, sorry, I thought you mean Chrome the browser.  I don't really know much about Chrome OS, however there are online converters for Pinyin, such as this one here.

 

Regarding the windows problem, what version of Windows are you using, and what program are using when you are trying to type pinyin.  Also, is it possible for you to take a screenshot?

Share this post


Link to post
Share on other sites
Guangxi Shane

Thanks for your help Imron. Pinyinput is working fine for me again. I figured out the answer to my question myself. :)

 

xiè xie nǐ

Share this post


Link to post
Share on other sites
imron

Out of curiosity, what was the issue?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...