Jump to content
Chinese-forums.com
Learn Chinese in China

speakgoodchinese


newyorkeric
 Share

Recommended Posts

Well... I have a new version of the Windows error... I have been trying to run the program on a Chinese version of Windows XP SP2... when I try to start the program... all I get is a black dos window and then a error message saying that it is going to close.

I tried to do the workaround, but I cannot identify what is the option... and cannot find anything indicating a US version of unicode. Any other suggestions about what to do?

Link to comment
Share on other sites

Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

  • 1 month later...
  • 2 months later...

I've tried installing SGC on the latest Debian but the process tells me that I need libzip.so.1.

Libzip.so.1 isn't available in any of the Debian repositories. I could try and install a rpm of it, but I've been told that could get nasty. If anyone has a solution... Thanks.

Link to comment
Share on other sites

  • 11 months later...

I'm still having a problem with this on Windows XP like others.

I followed roddy's steps to get it working but after right-clicking the properties on the sgc.bat I do NOT see anything related to "Options" or "current code page".

I see three tabs labeled "General", "Compatibility", and "Summary" and none them have anythiing useful even when clicking further into the "Advanced" sections, etc.

I also went to my Region and Language settings in Control Panel and made sure everything was set to United Sates and English, still no luck.

Any advice?

Link to comment
Share on other sites

Hey, I had the same bug on Vista and the current code page thing is not available, so I just adjusted the bat. Have to do so by running the windows editor as administrator and then just replace the command lines with:

sgc.bat=>

"@echo off

chcp 437

cd /d %~dp0sgc.exe"

singleword.bat=>

"@echo off

chcp 437

cd /d %~dp0singleword.exe"

that's how it worked fine for me.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and select your username and password later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...