Jump to content
Chinese-forums.com
Learn Chinese in China

  • Why you should look around

    Since 2003, Chinese-forums.com has been helping people learn Chinese faster and get to China sooner. Our members can recommend beginner textbooks, help you out with obscure classical vocabulary, and tell you where to get the best street food in Xi'an. And we're friendly about it too. 

    Have a look at what's going on, or search for something specific. We hope you'll join us. 
wobblythoughts

Help leaving Windows for Linux in China...

Recommended Posts

ipsi()

Wine won't run everything, though there is a compatibility website out there somewhere, which should make your life easier (provided the application has been tested recently). It's much better at running popular programs (Photoshop, Steam, Half-Life, etc), than less well known programs, like many Chinese RPGs for example. When I buy a new laptop, I'll probably convert this one to run Ubuntu, if I can. Be nice to have something running Linux :D.

Share this post


Link to post
Share on other sites
Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

ipsi()

Well, I've just recently switched from Windows to Ubuntu 7.10, and it's going pretty well so far. I got lucky, and the only thing on my laptop that didn't work out of the box was my wireless card. Well, that and the FN keys. (Well, some of them. The two most important - brightness +/- both work, though the only indication of that is that it becomes brighter or less bright).

I figured the wireless card would be the hardest, but I was wrong there, thankfully. I made sure I had a good look around first though, to find what I would need to ensure that it *did* work. Grabbed some drivers from somewhere, installed them via NDISWrapper, rebooted, and away I went, basically (well, I did have to edit a config file, but it was only adding "ndiswrapper" to the end).

It happily recognised my Treo (YAY!) so that synched fine. It also recognised my SD Card reader and my 40GB portable drive, so yeah. I'm basically happy.

Chinese was a bit harder than I really wanted it to be. It didn't help, I think, that I tried to install multiple Asian languages at once, which left me in the rather annoying situation of going into GEdit and finding that only some characters appeared. I eventually managed to get to the point where they all appeared, but some of them appeared in one font, and the rest in another. Believe me, that does not look good. At all.

Searched the internet for a bit, and found that I could just use the Simsun font from Windows. And now everything is good. SCIM is pretty nice, but I've gotta re-install OOo to ensure that it's compatible...

EDIT: SCIM works just fine with Open Office installed from DEBs downloaded from the website. Just had to enable Chinese support and change the default fonts. :D.

Works in Firefox though. :)

Share this post


Link to post
Share on other sites
Hero Doug

Hey there, just an unpdate to my previous info.

I used XP as my primary OS only because the internet connection was so horribly shoddy. Apparently this isn't really a Linux issue, it's more of a router issue.

In short, the newest kernel uses modern standards, while many routers don't properly support them.

The explination can be found here

http://lwn.net/Articles/92727/

and here

http://inodes.org/blog/2006/09/06/tcp-window-scaling-and-kernel-2617/

The fix can be found here

http://ubuntuforums.org/showpost.php?p=3617526&postcount=12

I personally replaced "vi /etc/sysctl.conf" with "sudo gedit /etc/sysctl.conf". Since I did this the net has been working (pretty much) on par with Windows.

Share this post


Link to post
Share on other sites
imron
I personally replaced "vi /etc/sysctl.conf" with "sudo gedit /etc/sysctl.conf".
Vi is your friend :mrgreen:

Spend a bit of time learning how to use it, and you'll never want to use another editor. It's one of the first things I install on a Windows box.

Share this post


Link to post
Share on other sites
ipsi()

Nah, EMACS!

Also, you should use gksudo instead of sudo when launching applications with a GUI.

Or something else in KDE, but I forget what exactly.

Share this post


Link to post
Share on other sites
imron

Try loading up EMACS to edit a file or do work over an ssh connection to a remote machine where latency is high, and you'll appreciate vi all the more :wink:

Share this post


Link to post
Share on other sites
ipsi()

Heh. Fair enough then.

Never had to do that yet.

Still discovering a few issues here and there with Ubuntu and Chinese:

SCIM doesn't seem to work with Scribus. Not a major issue, but still a pain. I suspect it's because Scribus was designed for KDE and not for Gnome.

The fonts are also kinda annoying. Basically, I like having Sanserif fonts normally, but I find the Chinese Sanserif font kinda hard to read, and it'd be nice to able to tell Gnome not to use the Sanserif font for Chinese, but to use Sanserif for everything else. Sadly, that doesn't work. Probably the easiest thing to do is just mess around with the Config files and hope I don't break anything too badly. It also irks me a bit that it's not possible (well, I don't know how anyway) to override a webpage's CSS with regards to Chinese and change it from Sanserif to Serif...

Bah. Still, by and large it's good. It's also nice that I can change the whole interface language just by rebooting X :D.

Share this post


Link to post
Share on other sites
imron
Basically, I like having Sanserif fonts normally, but I find the Chinese Sanserif font kinda hard to read, and it'd be nice to able to tell Gnome not to use the Sanserif font for Chinese, but to use Sanserif for everything else. Sadly, that doesn't work. Probably the easiest thing to do is just mess around with the Config files and hope I don't break anything too badly.
I mucked around with config files trying to do the same thing. I managed to get a sort of solution that worked for KDE apps (I run KDE), but that broke all Gnome apps in that Chinese characters just appeared as empty boxes (not good, because SCIM is Gnome). In the end, I gave up. One suggestion I read, is that if you have a copy of Vista, just copy the yahei.tff font which is a single font that displays both Chinese and English nicely, and then just set that as the default font.

Share this post


Link to post
Share on other sites
ipsi()

I suspect that I'll just have to modify the font files and replace all instances of Zhenkai Uni with Shanheisun Uni (and the same for the GB/Big 5 fonts). I can't use SimSun, as that prevents me from viewing at least one website, and possibly others. I wouldn't be surprised if the yahei.ttf font caused similar problems. That, and I don't have easy access to a Vista machine.

I'll play around with it a bit later on today and see what happens. I'll also probably post to the Chinese Ubuntu forums to see if anyone knows what's up with my SimSun problem. And how to get SCIM working with KDE apps that are being run under Gnome.

Share this post


Link to post
Share on other sites
ipsi()

It's not hard to do. I think all that has to be done is edit the /etc/fonts/local.conf fonts file to use ShanHeiSun over ZenKai Uni. I also modified /etc/fonts/conf.d/40-generic.conf and /etc/fonts/conf.d/65-nonlatin.conf. I'm not sure if they're necessary, but either way, I now have all my Chinese fonts appearing as ShanHeiSun. I suspect even if I changed my system font preference back to Sanserif, It'd keep using the Serif font for Chinese. :D.

Here's my /etc/fonts/local.conf for comparison:




serif


Times New Roman
AR PL ShanHeiSun Uni
AR PL SungtiL GB
AR PL Mingti2L Big5




sans-serif

Arial
AR PL ShanHeiSun Uni
AR PL SungtiL GB
AR PL Mingti2L Big5





monospace

FreeMono
AR PL ShanHeiSun Uni
AR PL SungtiL GB
AR PL Mingti2L Big5

Courier New
NSimSun


Share this post


Link to post
Share on other sites
imron

I still get butt-ugly fonts with that local.conf. The problem I'm having appears to be caused because my default locale is zh-cn, and the locale takes precedence over the order of fonts listed in the font configuration files, so it always uses the ascii characters from the Chinese font rather than from the nice Sans Serif font I choose. It's possible to override this, but then I get the square box problem with Gnome apps. :roll:

Share this post


Link to post
Share on other sites
ipsi()

Weird. I probably should have mentioned that I'm using Gnome, but I'm not sure if it makes a difference. I'll try changing my Locale, but I don't recall it making a difference. zh_CN.UTF-8, right?

Share this post


Link to post
Share on other sites
ipsi()

Must be a KDE problem, if that's what you're using, as switching my Locale still looks fine, though some of the fonts look a bit on the big side in Firefox, but that's a minor issue.

Share this post


Link to post
Share on other sites
imron

Did you log-out and log back in after changing the locale?

Share this post


Link to post
Share on other sites
ipsi()

Yep - CTRL + ALT + BKSP to reboot X, log back in and everything's in Chinese. As I said, it all looked fine apart from some larger fonts in Firefox, but that's probably a firefox-specific thing. It's also worth noting that I'm using Gnome. I'm downloading KDE now, and I'll see if that works for me.

Share this post


Link to post
Share on other sites
ipsi()

It worked fine for me in KDE... Admittedly, I don't think I changed the locale, but since KDE can change the locale on the fly, it shouldn't make a difference.

Anyway, uninstalling KDE now due to the insane number of applications it installs. I like my menus a little more basic, thank you :).

So yeah, I'm not sure what's up with your configuation. Do you have a ~/.local.font.config file by any chance?

Either way, the best I can say right now is that mine works... If you're still having problems, I can list what I did, but it wasn't much, just a few things to get KDE working properly - mostly SKIM and the language selector tool.

I'm using Ubuntu 7.10, and installed KDE on top of my existing GNOME install, so I'm not sure how much of a difference that makes.

Share this post


Link to post
Share on other sites
imron

Yeah, I think it might also be to do with the fact that I did a Chinese install and so there's some setting hanging around from that. They might also have fixed the problem in the latest release. I'm still running 7.04.

Share this post


Link to post
Share on other sites
ipsi()

Quite possibly. Seems more likely to be something fixed in the upgrade, I think, but it could go either way. If there's nothing essential on it, it might be worth a try upgrading it.

Share this post


Link to post
Share on other sites
imron

Yeah I tried the update, but the updater kept saying it couldn't verify the update and so wouldn't install. It's not really a big issue anyway, as I mostly use other operating systems, it's just an annoyance.

Share this post


Link to post
Share on other sites
renzhe

SCIM has a GTK frontend by default, but you can use SKIM, which is the same thing with a KDE/Qt frontend. SCIM itself is platform neutral. I use it under KDE (most of my apps are KDE apps) and don't have problem.

For me,

export LANG=en_GB.utf8

export LC_CTYPE="zh_CN.utf8"

solves all the problems I've had. The language for everything is English, but for typing, I use the Chinese locale. Works with SCIM. Unicode everywhere is the only sane approach to multi-language computing.

Could be a problem when you need to type using a different encoding (I imagine that this is often the case in China/Taiwan/Hong Kong), though....

Oh, and renzhe supports vim. Renzhe refuses to program unless there is a recent vim installation :mrgreen:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...