Jump to content
Chinese-forums.com
Learn Chinese in China

Forums Software Upgrade


roddy
 Share

Recommended Posts

Ok, as you can see things have changed a little bit. For a bit of background on why, you can go and see our very first blog entry here (which I now realize I posted from a different account, but never mind), while this topic will be host to screams of joy, terror and technical support.

Issues I'm aware of:actually I'm not sure I can think of any, but I have been in front of this screen for some time.

Private messages may look a bit of a mess - they now function as 'private conversations' where you can invite a number of people to . . . well, a private conversation.

The Google site search isn't working, need to get that fixed.

There's currently no Chinese language interface - if I can't find one I shall call for volunteers to make one.

Mobile version is not yet in place, but watch this space . . .

Redirects are in place, so old links / bookmarks should work fine - I can already see search engine traffic is ending up in the right place, so that's good.

The old admin note system is 'warnings' on here, so even if you got a message on the old system thanking you for a post or telling you a topic had been moved, that may have translated into a 'warning' level here. That shouldn't be anything to worry about, and it's only visible to you and admin staff. Will see what we can do about that later.

What else?

Link to comment
Share on other sites

Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

"Hide email address" doesn't seem to be checked by default in Settings; you have to go into Settings and check it manually after the upgrade.

Thanks for the tip, I just hid mine.

Otherwise... aiyo, I don't like change :-( But that's just me. I'll get used to it.

By the way, we have a working quote button now, is that intentional? I share the annoyance with overly long quoted posts, so I don't mind it one bit that we didn't have a quote button on here.

Edit after actually using the forums for a few minutes:

The space between posts is a bit too wide for my taste, seems that this was smaller in the old style.

Also I miss that, on the front page, you see the new threads and who posted on them last, but not how many replies there are. I would like to have that information back, if possible.

There are a few posts that ended up in the wrong places. The map in this thread and skylee's advice in this one are from other threads. (Btw I do really like that we now have thread titles in the link to the thread, with characters in them even!)

Link to comment
Share on other sites

"Hide email address" doesn't seem to be checked by default in Settings; you have to go into Settings and check it manually after the upgrade.

Ah, didn't vbulletin's run into problems. That's unfortunate since it was good software and had a long run.

On the new site design, first impression is that I prefer the old theme, particularly the fonts used. The new layout seem more "blocky" than the old one, with much more white spaces. I don't have a copy of the old site to compare it, too. Just a first impression.

In "Latest Discussions" on the front page, it lists the person who started the thread instead of the latest person to respond (as it was on the old site). I think the latter is better. Who started the thread becomes less relevant as time goes on.

Link to comment
Share on other sites

Yep, looks like the email preferences didn't get carried across. Couldn't see at first glance how to extract them from the old database so have just set everyone to 'hide email'. I'll see if I can bring the correct settings over later, if not it's probably not a huge deal. It doesn't actually display your email (I think), just allows the use of a form.

I'm kind of in two minds about the style myself, but considering the number of people who told me the old one was ugly I think I'll wait a while at least before making any substantial changes. Avatars are still there, but you also now have a 'profile picture' so you'll see blanks in some places (ie, your profile) until you upload one. And I think the new style means there's a bit more of a 'blank' where avatars would be when people don't have one (unless some people have actually lost their avatars. Mine's still there . . .)

The quote button is kind of on probation - I'll probably get around to removing it when I get annoyed by excessive use.

Link to comment
Share on other sites

Roddy,

Tried sending you a PM, but for some reason, it says you can't receive PM right now.

See the thread below. Is there some screw up in the conversion process? I don't remember Wushijiao mentioning BNU in the old thread before the conversion from vbulletin.

http://www.chinese-forums.com/index.php?/topic/25302-%E4%BB%A5%E8%8B%B1%E6%96%87%E4%B8%BA%E4%B8%BB%E7%9A%84%E8%A7%84%E5%88%99%E3%80%80%E7%BB%AD/page__pid__211743__st__0entry211743

以英文为主的规则 续

wushijiao

Posted 05 May 2010 - 12:40 PM

Looking for some ideas about how to live in Beijing for a month before I go to BNU for the fall semester 2010, what is a good quality place, with single rooms for a reasonable price. Im looking at around 400 dollars for the month. Anything lower than that is great. Even if its pay by the day its fine, I just need something !!

Thanks for any input, its greatly appreciated.

#8 User is offline CrisPal * Joined: 10-March 09

Posted 05 May 2010 - 01:03 PM

You come the right place,more advice may help you,Just like rivercao's talk about, Chinese are hospitable,and I'm in tianjin,if I can do a favor,that's my pleasure and I'm chinese,There will be some difficult at the beginning,but don't worry much about it,everything will be ok,good luck

Link to comment
Share on other sites

I should have just posted again instead of editing my above post all the time. There are some posts that ended up in the wrong thread, see my post above for a few examples. Also I saw a picture that ended up in the wrong thread, in the post by skylee (the rest of that post is on-topic).

Edit: and the document here, interestingly.

Link to comment
Share on other sites

Ok, sorry about that - look like the transfers got out of sync somewhere and some stuff wasn't in the right place. I've fixed it (at least I'm fairly sure I have, the above posts seem to be ok now). I closed the board down while retransferring some data. And also because I was kind of embarassed.

Right, there's a bunch of background images not showing up. I know exactly why, I just need to find where to fix it.

Gato, I've got a few pm's already - suspect it may be a permissions thing, you may still have mod status. Which reminds me, anyone who had mod status anywhere should check and see if they still do.

Link to comment
Share on other sites

It seems that the "go to new posts" feature isn't working. It sends me to the start of each thread. I assume this is a one-time glitch in that the last-post-read information just got lost in the transfer?

My first complaint: the "new post" button (as opposed to reply) took me at least 30 seconds to find. [it's that little green circle-arrow if anyone else is confused.] Is there a way that we could get a button that says "new post" or something that?

My first compliment: I like the reply to post! PLEASE keep it. I find it useful as it automatically includes the person to whom you are replying, and which post this is a reply too. I find that very useful.

Link to comment
Share on other sites

I used to go to these forums via this link:

http://www.chinese-forums.com/usercp.php

This doesn't work any more. It took me to a list of all threads which I'd contributed to and that have been updated. Then I'd click on "new posts" to see a list of threads which had been updated since my last visit.

What's the new way to do this?

Link to comment
Share on other sites

Go-to-new posts - I'd assume this is temporary. Let me know if it isn't.

The reply button (and others) should be easier to find now, the background image wasn't coming up. I couldn't fix it properly, but have fudged it. Hit CTRL+F5 to force a full reload.

I'll happily leave the reply to and multiquote buttons in-situ - as long as people actually edit the quotes down to what they are actually responding to.

That latest discussion block on the home page is a bit rubbish - it's latest topics, not latest posts. That wants fixed soonish.

Link to comment
Share on other sites

Wow, your tech support is amazing. Five minutes and it's fixed! Yes, I see the new reply button now. And the go-to-new-post is working, once I've read a thread, and there are new posts (like on this one), go to new posts took me to the first unread.

New complaint: the emoticons are not working. Or at least a couple I've seen, I can try to get a list together of non-working ones if that helps.

Link to comment
Share on other sites

Complaint #3: the 'View new content" seems to list all the threads by time of last post, irrespective of whether there is a new post in it or now. Is there a way to get only threads that have new posts too? Am I just missing something obvious?

Link to comment
Share on other sites

Adrian, I'm looking at ways to make new content and watched topics more accessible. Kind of fumbling around a bit though, as the back end is all new to me.

Emoticons - they should have been copied across (actually it might have been the same issue as with the buttons). If you can show me a post where they're not working I'll take a look.

  • Like 1
Link to comment
Share on other sites

Emoticons - they should have been copied across (actually it might have been the same issue as with the buttons). If you can show me a post where they're not working I'll take a look.

Two of them here: http://www.chinese-forums.com/index.php?/topic/25326-foreigner-in-chinese/page__view__findpost__p__212052 . It's showing up for me as the ASCII text, i.e. ":mrgreen:" and ":D". Maybe this is just a setting error on my part?

EDIT: OK, this is weird. In this post, which is new, they show up as emoticons for me. But in the old post, the one I referenced, they don't. Is anyone else seeing the same thing?

Edited by jbradfor
Link to comment
Share on other sites

Complaint #3: the 'View new content" seems to list all the threads by time of last post, irrespective of whether there is a new post in it or now.

Settings -> General Settings (start from the drop down under your username, top right)

Towards the bottom

Option 1: Show me all new content since my last visit

Option 2: Show me all new content that I have not read

That should do it. You'll want to 'mark board read' though (in the footer and perhaps elsewhere). 240,000 new posts!

Link to comment
Share on other sites

Emoticons - no error on your part, they just haven't been parsed. New ones are fine, they work if you edit a post and save, and I'm running a process now which should fix them all. God knows what else it'll break though.

Link to comment
Share on other sites

Join the conversation

You can post now and select your username and password later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...