Jump to content
Chinese-forums.com
Learn Chinese in China

  • Why you should look around

    Since 2003, Chinese-forums.com has been helping people learn Chinese faster and get to China sooner. Our members can recommend beginner textbooks, help you out with obscure classical vocabulary, and tell you where to get the best street food in Xi'an. And we're friendly about it too. 

    Have a look at what's going on, or search for something specific. We hope you'll join us. 
Tomsima

Wenlin blurry font

Recommended Posts

Tomsima

I just bought a new computer (surface pro 6), the screen is waaay crisper than the old samsung laptop ive been using for years. I promptly moved my wenlin software over to my new computer, and am amazed to see how fuzzy the text appears to be compared to the crisp text displayed on websites and other software. Is this issue due to wenlin's age, or is there an issue with using the software on newer computers? (I was on windows 10 on my old computer, so it shouldnt be an OS issue) Is there any way to solve this? I've tried all sorts of different fonts, they all display very clearly on pleco, but are still comparatively unclear on wenlin. Any solutions, or is it just the age of the software showing?

Share this post


Link to post
Share on other sites
Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

889

Try turning off ClearType, or whatever MS calls it. I don't use it all: I don't like what it does to many font faces.

Share this post


Link to post
Share on other sites
Luxi

Not blurry at all in my PC (Dell Optiplex + Windows 10), just tried all the fonts and various sizes in Wenlin and they all look crisp (the fonts look dated, but sharp). Turning Clear Type on and off didn't make any difference but it may be worth a try.  

 

Edit to add: maybe your Surface is too good for Wenlin. The display in my Dell isn't terribly good, I've seen better.

 

Share this post


Link to post
Share on other sites
Tomsima

Just tried turning cleartype off; it affects the menu bar at the top, but the text within wenlin itself remains unaffected. Never mind, I guess I'll just resign myself to fuzzy wenlin...

Share this post


Link to post
Share on other sites
Hofmann

If I remember correctly, Wenlin uses bitmap fonts. Your display is much denser than reasonably-sized bitmap glyphs. There's nothing you can do.

  • Helpful 1

Share this post


Link to post
Share on other sites
Tomsima

thanks hofmann, thats sorted everything out for me, it is the screen difference thats made everything so noticeable, and it appears theres nothing i can do about it. That being said, i would rather take the speed of wenlin over looks, so thats fine with me.

Share this post


Link to post
Share on other sites
Shelley

Just in case you couldn't or didn't read the link in my earlier post here it is. From wenlin help.

 

When the Smooth Text option is on, some fonts are displayed on the screen in a way you may find better looking. (Technically it is known as anti-aliasing.) Instead of using only one color, the edges of each character use a mixture of the text and background colors, which produces a smooth(or blurry) effect rather than sharp, jagged pixels. You can turn it off and on, and see which you like better. Some fonts (Monospace Pinyin, Plain Hanzi, and Bitmap Hanzi) are not affected by this option. Printing is also not affected. (Good printers have high enough resolution so that you can’t see the individual pixels anyway.) By default, the Smooth Textoption is on.

Share this post


Link to post
Share on other sites
Tomsima

thanks shelley, didnt see your post above there. turning off smooth text when im using a .ttf font results in the text being displayed wrongly. even turning off smooth text and using the built in fonts is a step backward in quality again. looks like there isnt a way to make .ttf, .ttc etc fonts display properly with smooth text off in wenlin. im guessing this is something to do with the bitmap font thing.

Share this post


Link to post
Share on other sites
Shelley

Oh well at least you tried.:)

Share this post


Link to post
Share on other sites
889

No, the .ttf fonts are TrueType, not bitmap, fonts. In Wenlin, the bitmap fonts are used only for the very obscure characters.

 

Two other things to try:

 

Change the display parameters. I think Wenlin likes old-fashioned ones.

 

Try running Wenlin in a compatability mode, if there is such a thing in Win10. I have Win7, yet run Wenlin under XP mode.

 

  • Helpful 2

Share this post


Link to post
Share on other sites
Tomsima

@889 Absolutely amazing, I ran Wenlin in compatibility mode for Windows 8, then selected the option that text was being displayed incorrectly. It has now solved the problem, the text is displaying super crisp HD. Really had given up hope, so thanks for your advice, very much appreciated.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×