Jump to content
Chinese-forums.com
Learn Chinese in China

  • Why you should look around

    Since 2003, Chinese-forums.com has been helping people learn Chinese faster and get to China sooner. Our members can recommend beginner textbooks, help you out with obscure classical vocabulary, and tell you where to get the best street food in Xi'an. And we're friendly about it too. 

    Have a look at what's going on, or search for something specific. We hope you'll join us. 
imron

Pinyinput - Type Pinyin with Tone Marks

Recommended Posts

imron

I've just uploaded a new version of pinyinput (see the original post). This version should fix the bug with checked input.

The installer has also been updated to provide more accurate error messages. A big thanks goes out to Anatoli for his help with the testing and debugging of the installer.

If you install this new version and you already have pinyinput installed, you might get a message that says "Error copying pinyinput.ime Pinyinput.ime is currently in use."

This means that a program you are running still has the pinyinput IME loaded, and so windows won't allow the new version to be copied over it. To solve this problem you will need to close any programs that have used Pinyinput (or just reboot your machine).

Also, there is another new addition. You can type ctrl-. to toggle checked/unchecked mode without needing to go to the config dialog.

Share this post


Link to post
Share on other sites
Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

Hero Doug

I was using is without the correction system on for a while so that's most likely why the tones were going on the last letter typed. It'll save a lot of time being done automatically.

The Wikipedia article isn't loading properly but from what I remember if you have a word like dui you'd first look for the A, and if there isn't an a, then move on to e, and if there isn't an e move on to i, and now that there is an i you use that one.

According to the rules I read dui would still have the mark above the i because the vowel sequence.

Maybe they just dumbbed it down for explination sake, I honestly haven't paid much attention to tone placement.

P.S. Thanks for the update.

Share this post


Link to post
Share on other sites
imron

From the article

The rules for determining on which vowel the tone mark appears are as follows:

1. If there is more than one vowel and the first vowel is i, u, or ü, then the tone mark appears on the second vowel.

2. In all other cases, the tone mark appears on the first vowel

(y and w are not considered vowels for these rules.)

There is also another algorithm

1. First, look for an "a" or an "e". If either vowel appears, it takes the tone mark. There are no possible pinyin syllables that contain both an "a" and an "e".

2. If there is no "a" or "e", look for an "ou". If "ou" appears, then the "o" takes the tone mark.

3. If none of the above cases hold, then the last vowel in the syllable takes the tone mark.

Pinyinput uses the first algorithm, because it's simpler.

So, in dui, the i takes the tone, but in diu the u takes the tone. And yeah, I can't say I paid much attention to tone placement before I started writing Pinyinput either :mrgreen:

Share this post


Link to post
Share on other sites
Hero Doug

Thanks for posting the exert. Looks like it just add's a bit to what I was using before. It's actually pretty simple to so I might even remember it.

Share this post


Link to post
Share on other sites
Jane Smith

How do you enable this program once installed? What's the IME called? Chinese ????? IME???

Share this post


Link to post
Share on other sites
imron

The IME is called Pinyinput, and the icon is a purple/blue circle with the tone marks rearranged to look like a face. It should be available from the language bar in the same place you access any other Chinese language input methods.

See this post for a better description of how to activate it.

Share this post


Link to post
Share on other sites
Jane Smith

Hi,

I am using win XP English. I've been able to get PINYINPUT installed and working. There are a couple of odd things, though.

1. There is a capsule-like blue or purple floating palette which has options for pinyinput. No problems.

2. I can change my languages from English to Chinese PRC and to Japanese. But the Language bar when using Chinese PRC does not expand the way it does with Japanese to include input method, etc.

Can you help me to know how to able to disable Pinyinput?

Also, how can I just type and get traditional and simplified chinese characters? In Japanese when I type in english characters the word changes to hiragana and from there I can press the space bar and get the appropriate kanji (chinese character).

How do I type pinyin and have that converted to chinese characters?

Also, I don't see options for input method, etc. in Chinese PRC such as the many options that are available under Japanese.

Any help with getting this working would be much appreciated.

Jane

Share this post


Link to post
Share on other sites
atitarev

I am not Imron but this thread is not about the usual Chinese IME's but the component he developped, which allows you input pinyin symbols with tone marks.

The default Chinese IME (for PRC), which ships with Windows is limited and has much less functionality than the Japanese IME. You can install the default Chinese IME (for Taiwan), which has the traditional characters and a soft keyboard and an IME pad.

Even better, download Microsoft Chinese IME 2003 - it has both versions and more functionality.

Share this post


Link to post
Share on other sites
imron

Jane, pinyinput was designed solely for the purpose of entering pīnyīn with tone marks. It cannot output Chinese characters. To type chinese characters using pinyin, you will need to install another input method like the ones atitarev mentioned. The blue floating capsule is the options menu for pinyinput. Every input method will have it's own one of these, and some of them don't have them at all. It is only displayed when pinyinput is active, and will disappear when another input method is in use.

There are several ways to disable pinyinput. The easiest way is just to select another input method from the language bar, or use one of the standard shortcut keys - ctrl-space toggles between Chinese/English, alt-shift changes language, and ctrl-shift changes input methods for the current language.

If the language bar isn't expanding when you select Chinese, then right-click on the language bar and there should be an option like "adjust language bar position" or something (I don't know the exact wording in English as I'm not running English XP). Selecting this option will cause the language bar to be correctly expanded.

If you'd rather not have pinyinput on the language bar at all, you can remove it by right-clicking on the language bar, selecting "properties" and then removing pinyinput from the list of available options. If you wish to remove it permanently from your computer, you can go to control-panel->add/remove programs, and from here you can choose to uninstall Pinyinput.

Share this post


Link to post
Share on other sites
toneproblems

Thanks for this great IME. However, I have a problem... when using pinyinput with Word (or any other program afaik) the letters with tones are inserted using the SimSun font. Given that I usually type using Times New Roman, I end up with loads of odd little Simsun formatted characters, meaning I have to select all / change to another font. Not insurmountable but a bit of a pain!

From memory, I think something similar happened when I used to use NJStar, so perhaps it is unavoidable. I don't really know much about IMEs, unicode, character sets, etc, so any pointers would be appreciated.

Share this post


Link to post
Share on other sites
imron

I noticed this problem during development, and tried to sort it out, but unfortunately it's a bit tricky.

When you write an IME, you have to register which language the IME is used for. This is used by the system to display the input method under the appropriate language in the languages dialog box.

Unfortunately some programs use this information to set the font used when typing.

So, the options were to either 1) Not have the IME listed under input methods for Chinese, 2) have some programs switch to a Chinese font when typing.

This problem is more pronounced in some programs than in others. For example, Word 2003 seems to only put the non-ascii characters (i.e. those with tones) in a different font, whereas Wordpad sets the font of all characters to the default Chinese font.

In the end, I decided that I'd prefer to have the IME listed under Chinese as that's where it rightly belongs. I'll have a further play around with things and see if I can find a way to solve both problems.

Share this post


Link to post
Share on other sites
toneproblems

Thanks for getting back to me about it. I had come to the conclusion that it must be to do with that... in fact within Word 2003 under Format / Font, there is the option to set the default "Latin text font" and the "Asian text font". If only it allowed me to select a Latin unicode font for the Asian font then I'd be fine, alas it only gives Simsun, MingLiU, etc. It is really frustrating in Word, as it alters only the characters with tone marks as you observed! When I highlight the text the "Style" property lists it as "Normal - Latin (Times New Roman) Asian (Simsun)."

Is there anyway you could produce a modified version of the IME that did not list it as Asian? Or could I edit it by downloading the IME compiler from Microsoft? I take your point that it should logically be listed under "Chinese PRC", but given that I will only ever use it to produce latin characters with tone marks, I would be happy to have it listed as a Latin IME.

Share this post


Link to post
Share on other sites
Guusj

I use OpenOffice to create wordtables in Chinese - for that I use eCode - and the new times roman font with unifont codes for the Pinyin and further the Dutch translation.

I have tried pinyininput - not in combination with eCode ! - to enter pinyin. After entering ma3 I get by hitting the enterknob: mǎ - so that works fine. However a following space give me not 1 space but 57 spaces. How will help me to resolve this problem ?

On the other hand at the moment I have created 2 macro workbars in OpenOffice Writer to enter the special pinyin characters. They contain each the 24 special pinyin characters in the forms: ā, á, ǎ, à, etc. and a1,a2, a3, a4, etc. They macros are created with the help of the free unicode input program: Quick Unicode Input.

Is there anyone with experience with pinyininput and OpenOffice Writer ?

Share this post


Link to post
Share on other sites
imron

toneproblems> Don't worry I haven't forgotten you. I'm still playing around trying to find a way to solve both problems at the same time, if I can't sort it out soon, I can make a special version.

Guusj> I've just installed OpenOffice, and I see what you mean. Typing numbers by themselves also seems to present a problem. I'll have a look into it, and post here when it's fixed.

Share this post


Link to post
Share on other sites
imron

Guusj>Pinyinput should now work correctly with OpenOffice. Check out the original post to download an updated version.

toneproblems> Send me an email, and I'll create a non-Chinese version for you (my email address is listed in the pinyinput "About" dialog).

Share this post


Link to post
Share on other sites
Guusj

RE: Guusj>Pinyinput should now work correctly with OpenOffice. Check out the original post to download an updated version.

toneproblems> Send me an email, and I'll create a non-Chinese version for you (my email address is listed in the pinyinput "About" dialog).

This new version of Pinyininput works excellent in Openoffice. Now i am able to type pinyin and the Dutch transalation simultaneously. So i do not think that a non Chinese version of Pinyininput is needed. Thank you very much for the great work you have done.

Greetings Guus Jansen.

At the moment i am not able to send you an e-mail, so i reply with this message.

Share this post


Link to post
Share on other sites
shanli

xiēxie ... it works for me.

after typing pinyin, how do I convert them to real Chinese words?

Share this post


Link to post
Share on other sites
imron

You have to use a different input method, like the MS Pinyin that comes with windows. Pinyinput is only for typing pinyin with tone marks. It fills a small niche for Chinese Input Methods, and isn't intended to be a full-blown input method for typing Chinese.

Share this post


Link to post
Share on other sites
SeekerOfPeace

Thanks a lot for providing such a great resource. It works great and it sure is making my life easier.

Thanks so much.

SoP.

Share this post


Link to post
Share on other sites
tiantian

Great program! Thank you!

But is it also possible to put it into the Tradidional Chinese (Taiwan) language bar? So far, it only appears when I use Chinese (PRC). Since I usually type traditional characters, I always have to swich to PRC to activate Pinyininput.

Thanks!

Tiantian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×