Jump to content
  • Sign Up

ZDT: Sound plugin problem


Recommended Posts

I am running Ubuntu 7.10, and ZDT 0.7.0. I cannot get the sound plugin to work, everytime I put the plugin-files in my plugin dir the program cannot find anything when restarting the program. every window has a error sign on it (see attached file). however if I remove the .jar files from the plugin directory, it works perfectly again. i have tried with roddy and the sound_0.2.0 file separately, and with both of them in the plugins dir at the same time. the same thing happens no matter how I do it...

the same thing happened when I tried it with the previous version of zdt.

And also, off topic, how do I get the annotator not to annotate 的 to dí, but de? and 好 sometimes comes with the 4th tone instead of the 3rd. i cant find a way to change this.

really love the new version, specially the flashcards!


Link to comment
Share on other sites

Hi Soffi,

Can you delete the sound-0.2.0.jar file? It is no longer compatible with 0.7.0. This was the original sound plugin and has since been replaced by the net.sourceforge.zdt.sound.adso plugin. I have now removed this original sound plugin download from the site since it's confusing.

Regarding your other issue, its sort of a dictionary thing. In the cedict dictionary, those characters you mentioned have multiple entries in the dictionary which you can see in the tooltip. In the pinyin display though, it's just showing the first one it finds. I'm open to suggestions on improvements the way it displays things though.


Link to comment
Share on other sites

ah, the other sound plug-in did the trick. thank you for the quick reply!

maybe a drop-down menu when you click a character/syllable in the annotator, where you can choose the suitable pinyin? at the moment, the character 大 annotates as dài, which is hardly the most common pronunciation. it's no biggie really, but it would be a nice future feature :P

Link to comment
Share on other sites

  • 4 months later...


I'm struggling to install the adso sound plugin for ZDT 0.7.0. (running XP).

I've downloaded the zip file, extracted the following 4 files and placed them in ..Program Files/zdt/plugins;

jl1.0.jar......................105,446............18/07/2007 15:24

mp3spi1.9.4.jar..........24,538..............18/07/2007 15:24

pinyin_sounds.jar.......7,344,480..........18/07/2007 15:24

tritonus_share.jar.......102,723.............18/07/2007 15:24

but ZDT fails to load them. They don't show in the Help-> About ZDT screen, or in Sound -> Preferences.

I've also tried deleting the Workspace and Configuration folders in my user area folder, but still no show.

Do I need to manually register them in some way ?

Thanks for any help...

Link to comment
Share on other sites

For the adso plugin, don't extract the files from the .jar. Just copy the .jar file as-is into the plugins directory (leaving it as one file), restart zdt, and enable it in zdt via windows->preferences->sound

Link to comment
Share on other sites

Join the conversation

You can post now and select your username and password later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...