Jump to content
Chinese-Forums
  • Sign Up

Chinese Characters on Firefox for Mac


xiaojiang216

Recommended Posts

大家好,

I'm having some trouble with certain character encodings on my Mac in Firefox.

I can view most Chinese websites without any problem, but there are certain websites that don't display the characters properly. (i.e.: www.people.cn)

This is what it looks like:

my.php?image=15951354yp3.png

I have the 字符编号 set to 用户定义... any ideas what the problem could be?

There aren't any problems on Safari, but I use Chinese-pera-kun a lot and other add-ons... :help

Link to comment
Share on other sites

I remember having a similar problem when I first got my Mac, and I seem to recall that it's related to the default Chinese font used by firefox. Try going into the options and changing the font used for chinese. I remember also that I ended up disabling one of the fonts at the system level so it would never be chosen. When I get home later today, I'll check which one it was.

Link to comment
Share on other sites

I have the same problem!

I have no idea of what to do. I tried to download firefox in chinese, but nothing changed. I downloaded other software but that changed nothing!:evil:

So for this kind of website im obliged to use safari. But, i do not like it at all!

Love firefox!:wink:

Link to comment
Share on other sites

I remember having the exact same problem, but I can't for the life of me remember the detailed steps for how I solved it, but I'm almost 100% sure it was a font problem. I thought I'd also posted something about it here, but I can't seem to find anything.

Anyway, I checked my computer and can't find which font I disabled (maybe I deleted it instead), however the font that Firefox currently uses on my Mac is "Hei". What happens if you set this font and then reload the page?

Link to comment
Share on other sites

Hey! I did it!

Thanks, imron! I found PMingLiu and clicked and dragged it to the Disabled Fonts folder. Now it works! Thanks for your help! :mrgreen:

Now I can use my precious 扩展组件!

Everyone that was coping with the beta version should just try disabling the fonts - it works!

Thanks again, imron!

Link to comment
Share on other sites

Join the conversation

You can post now and select your username and password later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...