Jump to content
Chinese-Forums
  • Sign Up

Cursor Jumping Back For No Apparent Reason


Glenn

Recommended Posts

There have been quite a few occasions when I'm typing a response and for some reason, when I hit Backspace, the cursor jumps back seven or so spaces and deletes whatever was there, so I end up losing something I wanted and keeping something I didn't. This seems to happen every time I Ctrl+"i" for italics, sometimes when I switch between English and Chinese, and sometimes for no reason that I can determine. Is anyone else having this problem?

Link to comment
Share on other sites

Not sure if this is the case, but under windows Ctrl-backspace is a common shortcut key to delete the previous word. You mention it happens when you press Ctrl-i for italics, so I wonder if perhaps the ctrl key is still down slightly when you then press backspace?

Link to comment
Share on other sites

This looks like a bug with the editor (+ or Chrome), which is a third party product used by the company which I license the forums software from. Hopefully the next upgrade (already overdue) will fix it, and hopefully I'll manage to do that sooner rather than later.

What I'd really like to do is switch to Xenforo, which Pleco is running on their forums and makes admins wet their pants in delight. But that would be a largish job.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

I've got this upgrade scheduled in for Monday, assuming I don't get any big lumps of translation work sent to me (if clients are reading this though, please don't let that stop you sending me big lumps of translation work). This month has been pretty hectic (and, yay, lucrative) with other work.

This will hopefully fix this and other bugs. There are also other changes to the editor, which you may or may not like. Personally I'm not a big fan of how the editor works now, but we'll see.

There's a major update to the forums software coming late this year / early next, although it'll likely be a month or two into the new year before I switched to it, so all the early adopters can find the worst of the bugs. I may however at that point opt to switch to Xenforo - it'd be a big job and there's always resistance to change, but the IPB upgrade would encounter a lot of the same issues. We shall see.

Link to comment
Share on other sites

Join the conversation

You can post now and select your username and password later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...