Jump to content
  • Sign Up

China Unicom Internet: Service Status/DNS?


Recommended Posts

When I moved into my apartment just over 2 months ago my estate agent organised a guy from China Unicom to come round and "connect" the Internet, which consisted of paying about ¥1400 for a year's connection, him testing the ethernet socket in my apartment and then giving me a PPPoE username/password, checking my laptop worked OK and then leaving.


I then bought a tiny, cheap and great router from JD, set up the WiFi, and have barely thought about it since then, as it's worked flawlessly ever since... until today when the DNS seems to be coming and going constantly on both laptop and phone.


So my question is: Is there a China Unicom website (or WeChat or whatever) that lists service status, outages etc?   Or even a website I can log into to check my account details?  I was literally given nothing apart from the ID and password.


Searching in English I found https://www.mychinaunicom.com/ (English website but seems to be only about mobile) and http://www.chinaunicom.com which is only in Chinese and doesn't seem to be customer-facing from what I can tell.  I wouldn't know what search terms to use in Chinese to find a service status page or similar.


Secondary question: is it worth using an alternate DNS in China?  Outside the GFW I used to use google DNS ( and for a while as it was much faster than my ISP's servers, but obviously that's a non-starter in PRC.  I've found a few alternatives that supposedly work but I wonder how leaky they might be if you're not using a VPN all the time.


I'm currently surviving connecting through my phone, but if anyone has recommendations I'd be pleased to hear them.




Link to comment
Share on other sites

I had a similar problem, not with CU though: all of a sudden I couldn't get a connection through the old router. But the connection was fine when I plugged the ethernet cable directly into my PC. Also fine when I used a small travel router I had around.


I wasted a huge amount of time researching the problem and playing around with the old router, to no success.


Finally just bought a new router and all is good again. (Seems some routers are vulnerable to a hack, so buy something different if you go this route.)

Link to comment
Share on other sites

I'm not sure if this is related to your problem, but I noticed that my DNS was getting messed up too. After a while I realised that it was Express VPN that was someone how messing up the DNS settings on my computer (not in any obvious way) and that if I changed the DNS server to something else, then back again it would work. So I wrote a little script to do it automitcally for me. 


If you are using Express VPN then you might start there rather than with the ISP, if not then I guess you can just ignore this, but it seems like most people in China use Express so I thought it was worth mentioning. 

  • Like 1
  • Helpful 1
Link to comment
Share on other sites

9 hours ago, markhavemann said:

it was Express VPN that was someone how messing up the DNS settings on my computer


Yes I've found this as well, although rebooting fixes it for me (on a Mac, OSX 10.14.6).  The latest beta seems even worse than the main release version I was using before, especially if it gets stuck and you have to force-quit it... it leaves things in a mess.


I'm online again now via direct ethernet connection, so my China Unicom connection is fine but the router is having some kind of problem — from a brief glance it looked like it wasn't getting an IP address. 


I'll do a factory reset, upgrade the firmware and set it up again (oh joy, Chinese-only menus for all the settings... thank heavens for the Zhongwen Chrome extension!).



Link to comment
Share on other sites

Just to follow up...


It turns out that the problem was the PPPoE server(s) on the other end of my Ethernet connection... at first I could connect directly with my laptop, bypassing the wifi router, but I soon found that to be unstable as well... the server was disconnecting after a time, or wasn't responding at all. So it wasn't just a DNS issue.


After connecting through my phone's 4G for about a week (too busy with work to sort it out) I tried PPPoE again and it was now working so I reconnected the router and it's been OK ever since. (Touch wood.)


Subsequently I found that while connecting directly through PPPoE, ExpressVPN was unable to connect to any servers at all.  I chatted online with their tech support and we tried a number of alternative DNS providers (114dns.com, Norton etc) to see if it was CU blocking them but it made no difference.  The error message is "Cannot detect Internet connection" but the tech support guy said this meant the servers couldn't be contacted. (Hmmm...)


I had no problems connecting to exactly the same servers through my 4G connection, which is also China Unicom.  And I have no problem connecting to them when I'm connected using WiFi to my router, which of course is running PPPoE to get my connection in the first place.


From this I conclude that ExpressVPN doesn't work when using the computer's PPPoE interface, rather than the WiFi or regular Ethernet interfaces.


This is with a very-recently updated ExpressVPN client v7.3.1 on a Mac running Mojave — OSX 10.14.6.



Link to comment
Share on other sites

Join the conversation

You can post now and select your username and password later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...