Jump to content
Chinese-forums.com
Learn Chinese in China

  • Why you should look around

    Since 2003, Chinese-forums.com has been helping people learn Chinese faster and get to China sooner. Our members can recommend beginner textbooks, help you out with obscure classical vocabulary, and tell you where to get the best street food in Xi'an. And we're friendly about it too. 

    Have a look at what's going on, or search for something specific. We hope you'll join us. 
imron

Pinyinput - Type Pinyin with Tone Marks

Recommended Posts

imron

I'm not sure what the grey boxes are. Are you able to provide a screenshot? Are you sure it's pinyinput that is causing the problem? What happens if you try uninstalling pinyinput, does the problem go away?

Regarding getting it to work, can you use it in other programs, e.g. Notepad?

Try this:

Open notepad

Select Pinyinput from the language bar (see the first post for a screenshot on how to do this). You will know it is selected when you see the blue pinyinput toolbar appear in the bottom-left hand corner of the screen.

Try typing ni3hao3ma

Share this post


Link to post
Share on other sites
Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

GVRone

They're called cutting marks. I solved the problem. So if someone talks about the same problem, you can refer this person to options in Word and try to explain to find words like 'cutting marks'. As for the second problem; it's been solved as well. I didn't have the language bar, so I added it via control panel. It's easy like you said and I'm satisfied. So thank you very much. Xièxiè nǐ!

Zàjiàn!

Share this post


Link to post
Share on other sites
cccina

Really thanks a lot, Imron. This is a really good software and does not crash, good job!

Share this post


Link to post
Share on other sites
Lao Che

I've been wondering how to type in pinyin. This will be a great help!

Also, I now realize my previous question about IMEs should've been directed to this forum. Somehow I missed it, but I now see it's an excellent resource.

Thanks for the work you put into this!

Share this post


Link to post
Share on other sites
mar4ela
I'm not sure what the grey boxes are. Are you able to provide a screenshot? Are you sure it's pinyinput that is causing the problem? What happens if you try cialis uninstalling pinyinput, does the problem go away?

Regarding getting it to work, can you use it in other programs, e.g. Notepad?

Try this:

Open notepad

Select Pinyinput from the language bar (see the first post for a screenshot on how to do this). You will know it is selected when you see the blue pinyinput toolbar appear in the bottom-left hand corner of the screen.

Try typing ni3hao3ma

Thank you imron for such stuff. I have on question - when we will be able to use this software with linux? :roll:

Share this post


Link to post
Share on other sites
glassley

I have been using Pīnyīnput for over a month and not a single glitch. Well done!

Thanks

Share this post


Link to post
Share on other sites
imron
when we will be able to use this software with linux?
Not in the short-term unfortunately.

Share this post


Link to post
Share on other sites
renzhe
Thank you imron for such stuff. I have on question - when we will be able to use this software with linux?

While you're waiting for pinyinput to come out for Linux, you could use SCIM's pinyin input, which is not bad.

Share this post


Link to post
Share on other sites
Meng Lelan

I don't know if this question has already been answered? I have Pinyinput and Google Chinese IME. Is there some way to type a character in MS Word and have the pinyin appear below the character automatically? That way I can type up lessons for my students - both characters and pinyin.

Share this post


Link to post
Share on other sites
roddy

Yes, but it's nothing to do with Pinyinput - try this. Pinyinput itself doesn't have the character to pinyin mapping needed.

Share this post


Link to post
Share on other sites
Meng Lelan

Wow Roddy that one really worked for me, thousands times better than Pinyinput! Makes Pinyinput obsolete already. Thanks!

Share this post


Link to post
Share on other sites
imron
Makes Pinyinput obsolete already.
This feature of MS Word was around long before pinyinput existed, but it doesn't solve the main problem that spurred me to develop pinyinput. I wanted to be able to type pinyin with tones in any application at any time (word processors, web browsers, file names, etc). So pinyinput is not quite obsolete yet, it's all about picking the right tool for the right job :) Also, you might find that many of your students dislike having the pinyin written above the characters (I know I do), in which case it's still useful to be able to type pinyin separately.

Share this post


Link to post
Share on other sites
Meng Lelan
Also, you might find that many of your students dislike having the pinyin written above the characters (I know I do), in which case it's still useful to be able to type pinyin separately.

That's exactly what I was doing - characters with no pinyin, or the pinyin would be listed separately, and the whole class freaked out.

So I promised them a version with characters having pinyin written above the characters.

I'm planning to phase out the pinyin more gradually though.

Share this post


Link to post
Share on other sites
snowie

THANKS!!!!! just the thing i've been looking for. will let you know if i have any problems with it. mwuaaah

maria

Share this post


Link to post
Share on other sites
Callecutta

This is great. Actually it's beyond great. Three cheers for you, you've made one Swede very, very happy.

Share this post


Link to post
Share on other sites
Chacha93160

Hi,

I was using Pinyinput for a while, with no problem. A great software, really; many thanks for the inventor.

But now, something is getting wrong: the numeric keypad doesn't work anymore when i select the pinyinput IME (but the keys above the letters are OK)

This is weird, because absolutly nothing has been done on this computer except Microsoft Updates of course. So i suspect one of those...

Has anyone had the same problem ? For Imron: is there anything i can check ? (i 've tried reinstallation, reboot, connection with another account...no success)

Thanks for your reading,

Richard

Some Inf.:

XP Pro US/FR/CN

Office 2003 SP3

French Keyboard

Share this post


Link to post
Share on other sites
imron

Hi Richard,

I'll have a look at the problem a little later today once I get in front of a windows machine. In the meantime, I guess using the normal number keys is the best workaround.

Did the keys on the numeric keypad work previously, and have you tried it using a different keyboard layout as the default?

Share this post


Link to post
Share on other sites
imron

Ok, I see what it is doing now. It appears to be ignoring the state of the numlock key, and always treating the keys as if numlock is turned off. I'll put it on my list of things to do.

Share this post


Link to post
Share on other sites
Chacha93160

Hi Imron,

Thanks for your quick answer,

"Did the keys on the numeric keypad work previously" :

My wife (she is a regular user of your software :D ) used it during the last two weeks of December 2008 and it worked. But at the beginning of this month, she used it again and it didn't work any more.

"have you tried it using a different keyboard layout as the default?" :

I've tried the following settings: on Regional and language option, tab Region Option > standards and formats = English (US), location = US, tab Languages > Language used in menus and dialogs = English. After logoff/login, i've selected US keyboard on the Keyboard Layout Setting of Pinyinput and test > same problem.

Of course, we're going to use normal keys for the time being (not a critical bug indeed !)

Again, thank you for your help,

fei chang gan xie !!! :D

Richard

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...