Jump to content
Chinese-forums.com
Learn Chinese in China

  • Why you should look around

    Since 2003, Chinese-forums.com has been helping people learn Chinese faster and get to China sooner. Our members can recommend beginner textbooks, help you out with obscure classical vocabulary, and tell you where to get the best street food in Xi'an. And we're friendly about it too. 

    Have a look at what's going on, or search for something specific. We hope you'll join us. 
imron

Pinyinput - Type Pinyin with Tone Marks

Recommended Posts

Joe-SiliconValley

Having a problem with the latest version (1.1.0) on two different machines, one x64 Windows and one x86 Windows: I installed Pinyinput into my English (US) IME, and now while working in English I am switched to the Pinyinput keyboard whenever I hit Ctrl-Shift.

This happens whether or not I assign my own hotkey combination to Pinyinput. The Ctrl-Shift hotkey can't be turned off in Text Services and Input Languages / Advanced Key Settings because it does not appear there. This did not happen in a previous version I installed on x86 Vista. This is a problem as I hit Ctrl-Shift-[left arrow] often to select entire words.

I suppose I could install Pinyinput into the Engilsh (AU) IME instead, but is there perhaps a way to fix this?

Share this post


Link to post
Share on other sites
Site Sponsors:
Pleco for iPhone / Android iPhone & Android Chinese dictionary: camera & hand- writing input, flashcards, audio.
Study Chinese in Kunming 1-1 classes, qualified teachers and unique teaching methods in the Spring City.
Learn Chinese Characters Learn 2289 Chinese Characters in 90 Days with a Unique Flash Card System.
Hacking Chinese Tips and strategies for how to learn Chinese more efficiently
Popup Chinese Translator Understand Chinese inside any Windows application, website or PDF.
Chinese Grammar Wiki All Chinese grammar, organised by level, all in one place.

imron

Ctrl-shift is the default windows shortcut key for changing to the next input method of the current keyboard language.

Previously you presumably only had one input method installed under EN-US and so you didn't notice it. Now that Pinyinput has been installed under EN-US you have two keyboard layouts under this language - the default US keyboard and Pinyinput - and so this keyboard shortcut is causing the problem.

Edit: After some testing, it also appears that for me, this is only activated if you press ctrl-shift and then release either the ctrl or the shift key before moving the arrow keys to select. If you move the arrow keys before releasing either the shift or the ctrl key, then the input method won't change.

Anyway, you can disable the shortcut if you want in the keyboard preferences, below are the steps under XP, but they should be more or less the same under later versions.

First right-click on the language bar and then click "Settings..."

This will bring up the Text Services and Input Languages box.

In the preferences section, there will be a button called: Key Settings

Click on this and in the box, the top item will be called "Switch between input languages"

Select this item and click the button that says "Change Key Sequence"

Then click off the check box that says "Switch Keyboard Layouts" to disable this (unfortunately you can't really change the keyboard shortcut for this, except to change it to alt-shift, but then ctrl-shift automatically becomes "Switch Input Language" which would still give you the same sort of problem so the only real option is to disable it).

Note, that once you've done this you will no longer be able to use the keyboard to cycle through the multiple keyboards in the same keyboard language (but you will still be able to use other shortcut keys to switch and you'll still be able to use alt-shift to switch between keyboard languages). If this is going to be an issue, then installing under the EN-AU locale would also solve the problem because then the EN-US keyboard language would only have one keyboard again.

Share this post


Link to post
Share on other sites
Joe-SiliconValley

Thanks Imron, looks like I neglected to drill down one more button. In Vista and Win7 "Switch Input Language" and "Switch Keyboard Layout" have separate sets of radio buttons, and I had long ago assigned Alt+Shift to switch IMEs to avoid this same problem. Now I've turned off the keyboard switching keys, and all is well. Keep up the good work!

Share this post


Link to post
Share on other sites
DespikableMi

Pinyinput is nice but hitting the number keys is too slow. Can the software be modified to suggest possible words just like in most Character Pinyin input?

Share this post


Link to post
Share on other sites
imron
Can the software be modified to suggest possible words just like in most Character Pinyin input?

You mean where you then have to type a number to select the word you want? ;)

I have no plans to make such modifications, however the source code is available if anyone else wants to do it. I don't imagine it would be a trivial task however, and would dramatically increase the download size. Google and Sougou both ship with large databases of vocab to support intelligent sentence completion.

Share this post


Link to post
Share on other sites
黎佳铮

Wow!!! It's very great! You know, i always copy paste pinyin from google translate and it's sometimes annoying because i have to online.

Thank you so much especially for Imron! Now, I dont have to online everytime I want to input some pinyin. Thank you! :D

Share this post


Link to post
Share on other sites
Demonic_Duck

Just downloaded this, looks really useful. I'd changed my default QWERTY keyboard layout to be able to input pinyin tone marks, but it was cumbersome to use, this is much better. Cheers!

Share this post


Link to post
Share on other sites
krzemian

How do I input sheì or sheí (I understand these are legit Mandarin words, I've got them in Rosetta Stone) in the "correct" mode? By default it gives me shèi and shéi.

Share this post


Link to post
Share on other sites
imron
How do I input sheì or sheí

This is incorrect pinyin. If Rosetta Stone is using it, then they have made a mistake. There are very clear rules for which vowel takes the tone mark and for these words it should be shèi and shéi.

Pinyinput will still allow you to type incorrect pinyin if you really want to, but you need to change it to "unchecked mode" (click the button that looks like a check mark on the pinyinput toolbar).

Now you can place a tone mark over any vowel you like, by typing the tone number after the vowel, e.g. to enter shèi you would type she4i and to enter sheì you would type shei4.

Share this post


Link to post
Share on other sites
wiccaspell

I have mirosoft word 2007, on a windows 7 every time i type in pinyin it crashes, i can type one word and space then the moment i hit another letter -crash-, this happened on my old laptop too, i think it had 2010 word though (not sure, was a year ago) also windows 7, but i forgot how i fixed that because it eventualy worked.

Share this post


Link to post
Share on other sites
imron

Which version of pinyinput are you running? Also, can you let me know what letter combination you are typing in that causes the crash?

Share this post


Link to post
Share on other sites
wiccaspell

sorry guess its been a while i was using 2003 not 2007 @[email protected] i just borrowed my friends 2007 and i can type now w.o crashing how ever now im getting a different problembe letters with the - and v over them the letter turns into a ? mark with a box around it =/ the version im using is 1.1.0

Share this post


Link to post
Share on other sites
imron

Are you able to take a screenshot of what you mean, and also let me know what specific character combination you are typing in? (e.g. ni3 hao3)

Also, could you please take a screen shot of the Pinyinput settings dialog box so I can see what your configuration settings are.

You can either post them here, or send them via email (my email address is specified in the pinyinput "about" box).

Share this post


Link to post
Share on other sites
imron

That looks very much like a problem with the fonts missing that particular character. It's strange though because if I set the font to Calibri on a test machine it works fine for me.

Can you see what happens if you set the font to "Arial Unicode MS"

Share this post


Link to post
Share on other sites
wiccaspell

ah ok it works with other fonts guess it was just that one =/ either way thanks i can finaly get started on my chinese hw haha

Share this post


Link to post
Share on other sites
imron

No problem. Good luck with your homework :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Click here to reply. Select text to quote.

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...